Tag Archives: ошибка joomla 2.5

Ошибка на сайте Warning: Declaration of JParameter:

В один прекрасный момент сайт выдал ошибку:

Warning: Declaration of JParameter::loadSetupFile($path) should

be compatible with JRegistry::loadSetupFile() in
/home/…/docs/libraries/joomla/html/parameter.php on line 0

Пропала меню, перестало работать половину вкладок, корзина переименовалась на английский, доступ к админке стал не возможен …

После разбора, выяснилось, что эта ошибка возникла из-за версии php.

Joomla версии 2.5 не поддерживается php 7.0, поэтому нужна версия php 5.6.

https://www.joomla.org/about-joomla/technical-requirements.html

Сменил php версию на хостинге на версию 5.6 и все работает.

Смена php 5,6

Смена php 5,6